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1. Formål og rettigheder 

Denne note skal gøre det ud for en kort manual til programmet Perspective Modeler. 
Formålet med programmet er at stille et arbejdsredskab til rådighed, der er i stand til at 
tegne perspektivisk korrekt. Programmet kan eventuelt bruges i undervisningssammen-
hæng ved gennemgangen af principperne bag perspektivet. Med det vil man være i 
stand til hurtigt at afprøve forskellige situationer interaktivt og derved kunne udforske 
perspektivets regler i starten, før man selv kan udføre tegningerne korrekt. Denne note 
er som nævnt en manual til brug af programmet, den indeholder ikke en teoretisk gen-
nemgang af principperne bag perspektivet. Den må du finde andet steds, eventuelt i min 
bog: Erik Vestergaard. Matematik i perspektiv. Forlaget ABACUS, 1995 På min hjem-
meside www.matematiksider.dk/perspektiv_down.html, hvorfra også Perspective Mo-
deler kan downloades, kan du desuden downloade noten Perspektivet, som dels indehol-
der teori om perspektivet, dels indeholder tutorials og opgaver, som instruerer brugeren 
i Perspective Modeler. Den kan være en god start, og kan endda danne grundlag for et 
matematikforløb. Programmet er fremstillet af den meget rutinerede programmør Alex 
Vakulenko fra Ukraine (se www.oberonplace.com) efter mine instruktioner. Program-
met er i skrivende stund nået til version 1.2. Programmet er dog ikke i stand til at fjerne 
skjulte linjer – det er ganske kompliceret at fremstille en algoritme, som kan gøre dette i 
ethvert tænkeligt tilfælde! Måske i en senere version ..... Vedrørende rettigheder:  
 
Programmet må ikke benyttes i kommerciel sammenhæng, ellers kan det frit anvendes! 
Undertegnede påtager sig naturligvis intet ansvar såfremt programmet mod forventning 
ikke skulle virke eller måtte forårsage problemer på brugerens computer. Programmet 
må ikke distribueres fra andre sites end fra:  www.matematiksider.dk. 
 
Som en introduktion til programmet og dets muligheder kan du også studere nogle on-
line tutorials på siden www.matematiksider.dk/perspektiv_over.html. God fornøjelse! 

27. maj 2005 ved Erik Vestergaard 
 
2. Begreber og opbygning 

For at få det fulde udbytte af programmet er det nødvendigt, at du forstår hvordan pro-
grammet er bygget op. De fleste programmer, som kan tegne perspektiviske tegninger i 
forskellige sammenhænge, gør det på en måde så brugeren ikke behøver at sætte sig ind 
i perspektivets indre natur. Fordelen er, at det er nemt at gå til, ulempen er, at du mister 
styringen. Med Perspective Modeler har du den fulde kontrol. Til gengæld er der nogle 
få begreber, du skal sætte dig ind i: For det første har vi Verdens koordinatsystemet WC, 
hvori scenen med dets objekter er beskrevet. Koordinaterne heri er ( , , )x y z  med z-
aksen som den lodrette akse. Scenen betragtes fra øjepunktet E (Eye-point), angivet ved 
( , , )x y zE E E  i WC. Dernæst skal der angives et billedplan (View-plane), hvori ethvert 
objektpunkt skal projiceres ved centralprojektion: Billedpunktet hørende til et objekt-
punkt er skæringspunktet mellem billedplanen og linjen gennem objektpunktet og øje-
punktet (figur 1). Her er samtidig hemmeligheden bag konstruktionen: For observatøren 
med sit øje i øjepunktet vil det projicerede billede og objekterne selv se ud til at være 
sammenfaldende.  
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Figur 1 

 
 
Til ethvert billede hører altså et øjepunkt, som følger med billedet, og hvorfra billedet 
skal betragtes, såfremt det fuldstændigt skal ligne det rigtige 3-dimensionale sceneri. 
Betragt figur 2: Et kamera optræder her i øjepunktet E. Billedplanen (View-plane) kan 
specificeres ved en normalvektor n og et punkt. Almindeligvist ønsker man en bestemt 
distance d fra øjepunktet til billedplanen. Da kan man som punkt vælge  bestemt ved 

. Dette punkt vil da være det punkt, som er lige udfor øjepunktet, hvor-
for det betegnes hovedpunktet eller Centre of Vision. Kigger man fra øjepunktet vinkel-
ret ind på billedplanen, vil man kigge lige ind på . Eftersom det er naturligt at kigge 
vinkelret ind på en plan, vil vi af praktiske årsager betegne retningen angivet ved 

vC
vOC OE d n= − ⋅

vC
n−  

som synsretningen (Viewing Direction), velvidende at øjet i princippet kan se i alle ret-
ninger fra E.  
 
Figur 2 
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I Edit Perspective kan du indstille kameraets position ved øjepunktet (Eye-point) og 
kameraets orientering ved synsretningen (Viewing direction) samt -vektoren (View-
Up-Vector). Sidstnævnte er en praktisk vektor, som er med til at bestemme, hvad der er 
”op” i billedplanen. Det kan være, at kameraet er tiltet lidt, så ”op” ikke er det samme 
som ”op” i verdens-koordinatsystemet. Kameraet har nemlig sit helt eget reference 
system kaldet Viewers Reference Coordinate-system (VRC): Et system af normerede og 
indbydes ortogonale basisvektorer . Internt i programmet vil n vælges som den 
normerede vektor, som er modsat rettet den brugeroplyste synsretnings-vektor. Dernæst 
vil 1. basisvektor u i VRC bestemmes på basis af den brugeroplyste View-Up-Vector via 
følgende formel: 

upv

( , , )u v n

up up( )u v n v n= × ×  og endelig vil den 2. basisvektor v i VRC blive 
beregnet ved krydsproduktet v n . Ved denne konstruktion kommer vektoren v, 
som angiver ”op” i VRC til at ligge i samme plan som n og , som vist på figur 3. 
Man kan sige, at brugeren ved at angive en -vektor slipper for at skulle finde en vek-
tor, som står vinkelret på n. Det gør programmet for ham! Default-værdien for  er 
valgt som (0,0,1), men værdien kan altså ændres, så kameraet tiltes. I de fleste situa-
tioner vil (0,0,1) kunne bruges, men hvis man ønsker at kigge på en scene lodret oppe-
fra, så synsretningen er (0,0,–1) vil man være nødsaget til at ændre  vektoren. Så kan 
man for eksempel vælge (1,0,0).  

u= ×

upv
upv

upv

upv

 
Figur 3 

 
 

 
Når øjepunktet befinder sig midt i en scene fyldt med objekter kan der opstå problemer 
med det perspektiske billede: Eventuelt vil man få ”kunstige billedpunkter” af objekt-
punkter, som ligger bagved betragteren, eller man kan endda få problemer med at bil-
ledpunktet ikke er defineret, hvis øjepunktet befinder sig oveni i nogle objekter. Derfor 
er det almindeligt at definere et såkaldt synsvolumen (View-Volume), som alle objekter 
beskæres i forhold til, før de projiceres i billedplanen ved den perspektiviske afbildning. 
Formen af dette volumen er en pyramidestub med toppunkt i øjepunktet og begrænset af 
fire stråler fra øjepunktet gennem hjørnerne i det såkaldte synsvindue (View-Window), 
der er et rektangel i billedplanen med sider parallelle med u-aksen og v-aksen. Rektang-
let kan således specificeres ved diagonalpunkterne  og . Endelig 
er pyramidestubben begrænset af to planer parallelle med billedplanen: Front-clipping-
plane og Back-clipping-plane. Disse er specificeret ved en ”afstand” til billedplanen, 
som regnes med fortegn: Hvis planen er tættere på øjet end billedplanen regnes afstan-
den positiv, og hvis planen ligger bagved billedplanen regnes ”afstanden” negativ. Hele 
situationen er beskrevet på figur 4 på næste side.  

min min( ,u v ) )max max( ,u v
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 Figur 4 
 

 
 
 
 
 
Figur 5 
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Figur 5 viser et generelt rektangulært View Window, angivet ved punkterne  
og . Lad , 

min min( ,u v )
)max max( ,u v A vv AEC= ∠ B vv BEC= ∠ , C vv CEC= ∠  og . Kun 

den første vinkel er indtegnet på figuren. Vinklen 
D vv DE= ∠ C

{ }max , , ,A B C Dw v v v v=  kaldes da 
for synsvinklen. Arkitekter angiver til tider et såkaldt distanceforhold i stedet for en vin-
kel: { } { }v v v v v min min max maxmax , , , max , , ,EC AC BC CC DC d u v u v= . I Edit 
Perspective dialogboksen i programmet kan du vælge Custom i Field Of View drop-
down listen, hvorefter du helt frit kan angive et synsvindue via værdier for , , 

 og ; også et som ikke indeholder hovedpunktet . Imidlertid vil man ofte 
vælge et, som indeholder hovedpunktet og ligger symmetrisk omkring dette. Derfor er 
der i ovennævnte dropdown liste også muligheden Angle, hvor du kan indtaste en øn-
sket synsvinkel, og en række distanceforhold: 1:2, 1:1, 2:1, 3:1 og 4:1. Sammen med en 
værdi for 

minu minv
minv maxv vC

u v ratio− , definerer det View Window. Kig nærmere hvordan i afsnit 5.  
 
 
3. Scenen og projektionerne 

Perspective Modeler viser som default 4 forskellige projektioner: 3 ortogonalprojek-
tioner i henholdsvis xy-planen (Top), xz-planen (Front) og yz-planen (Left) samt natur-
ligvis selve perspektiv central-projektionen (Perspective). Det er i felterne med ortogo-
nal projektionerne, at man skal frembringe sine objekter og beskrive, hvorfra og hvor-
dan de betragtes. Resultatet kan så betragtes i feltet med perspektiv projektionen. Som 
default vises de fire projektioner 2 og 2 (2:2). Under View > Layout kan du dog vælge 
at ændre visningen til 3:1, hvorved du vil få de tre ortogonal projektioner i venstre side 
og perspektiv projektionen i højre side. Du kan i menuen View vælge at tilslutte/fjerne 
målestokke (Rulers), gitterlinjer (Grid) og aksevisning (Axes). Bemærk, at for at arbejde 
i et bestemt felt skal du klikke på det, hvorved der dannes en rød ramme udenom feltet: 
Feltet er aktiveret. Når du har aktiveret et felt, kan du ved at højreklikke endnu en gang 
på det, få vist feltet i hele området! Når du igen højreklikker i feltet kommer du tilbage 
til normal visning. Med View > Zoom In og View > Zoom Out (F2/F3) kan man zoome 
yderligere ind ved at trække et rektangel ud. Som default vises en tredimensionel scene 
på med origo beliggende i centrum af denne kube. Du kan ændre en 
scenes størrelse, placering og gitter via menuen View > Scene Properties (F6). I dialog-
boksen kan du også ændre farve og tykkelser på objektlinjer, gitterlinjer (Grid), horisont 
gitterlinje (Horizon Grid Line), horisontlinje (Horizon), linjer til forsvindingspunkter 
(Vanishing Lines) og ”sigtekornet” (Centre Of View) samt vælge, hvor mange decimaler 
data skal angives med (Unit Precision). Bemærk, at du under Grid Properties kan 
ændre de primære og sekundære gitterlinjer. Hvis der anbringes et 0 i feltet Major Grid 
Spacing, så bliver disse primære gitterlinjer slet ikke tegnet! Rotation Increment angiver 
hvor mange grader, der drejes med, når piletasterne benyttes til at rotere objek-
ter/kamera orientering med. Nudge Offset angiver tilsvarende skriftlængden, når piletas-
terne benyttes til at flytte objekter/øjepunkt med. Per default er Nudge Offset sat til 
maskevidden i det sekundære gitter (Minor Grid Spacing), men kan også vælges frit. 
Hvis man ønsker at skrive nogle instruktioner til en fil, så kan det gøres via menuen 
View > Scene Notes...  

40m 40m 40m× ×
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4. Objekterne 

For at det bliver interessant, skal man skabe nogle objekter. Man vælger et værktøj og 
trækker det pågældende objekt ud i et af de tre projektionsfelter. Bemærk, at cursoren 
skifter udseende. Man kan aktivere Snap-to Grid, hvis man holder Shift tasten nede, 
samtidigt med at man trækker objektet ud. Det gør, at det er lettere at lave objekter med 
pæne mål. Man kan dog naturligvis også markere objektet med Pick Tool bagefter og 
rette det til via objektets data i den grå bjælke forneden. Du kan både arbejde i absolut 
tilstand eller i relativ tilstand alt efter om Rel-knappen er presset ned eller ej. Bemærk, 
at Position angiver koordinaterne for objektets midtpunkt. Objektets midtpunkt er defi-
neret som midtpunktet af den mindste rektangulære kasse, som er parallel med akserne 
og som omslutter hele objektet.   
 
Line Tool Man kan trække en linje ud. Hvis man holder Ctrl-tasten nede 

mens man trækker linjen ud, vil linjen enten være parallel med 
en af akserne, eller den vil få en vinkel på 45° i forhold til 
disse. 

Rectangle Tool Man kan trække et rektangel ud. Holdes Ctrl-tasten samtidigt 
nede vil man få skabt et kvadrat.  

Box Tool Man kan trække en kasse ud. Redskabet virker lidt specielt idet 
et 3D objekt skal fremstilles i et 2-dimensionelt felt: Man akti-
verer først det projektionsfelt, hvori man ønsker at lave kassen. 
Så trækker man et rektangel ud i feltet og efter venstre muse-
tast er hævet er kassen stadig ikke færdig, idet den sidste di-
mension skal laves. Når man bevæger cursoren op og ned kan 
man i de øvrige felter se, at der ”kommer en ekstra dimension 
på”. Når man venstreklikker en gang til er kassen færdig. Hvis 
man under konstruktionen holder Ctrl-tasten nede, kan man fx 
lave en terning. Prøv dig frem. Funktionen her er lidt indviklet.  

Ellipse Tool Man kan trække en ellipse ud. Hvis Ctrl-tasten holdes nede 
bliver objektet til en cirkel. En markeret ellipse kan redigeres 
via menuen Object > Properties... (F4). Her kan du ændre stor-
aksen og lilleaksen og eventuelt beskære ellipsen til et bestemt 
vinkel interval regnet i grader, samt angive, hvor mange 
linjestykker ellipsen skal bestå af (Flatness). Endvidere kan 
centerets koordinater redigeres. Man kan også redigere vinkel 
intervallet, lilleaksen og storaksen interaktivt med hjælp af 
Node Edit Tool. Bemærk, at hvis man klikker på ellipsen med 
dette værktøj fremkommer der nogle punkter man kan rykke i. 
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Curve Tool Med dette redskab kan man lave en simpel bezier-kurve. Man 

holder venstre musetast nede, mens man trækker cursoren. Når 
man hæver venstre musetast og efterfølgende bevæger musen, 
vil en kurve vises. Man slutter kurven af ved enten at venstre-
klikke et sted eller holde venstre musetast nede mens man 
trækker og hæver venstre musetast. Bemærk, at man kan redi-
gere en bezier-kurve med Node Edit Tool: Klikkes på kurven 
med dette redskab kommer der op til to ”kontrolhåndtag” til 
syne. Dem kan man rykke i og derved ændre kurven. Bemærk, 
at man undertiden ikke kan se kontrolhåndtaget i den ene ende 
af kurven. For at få fat i det kan man så holde Ctrl-tasten nede 
mens man trækker i den ende af kurven, hvor håndtaget ikke 
kan ses. Så skulle det gerne komme til syne ...  

Parametric Functions Med denne facilitet kan man få tegnet en parametriseret rum-
kurve. Man indtaster koordinatfunktionerne med parameter t. 
De tilgængelige funktioner og  deres parametre kan ses ved at 
klikke på den lille knap med xf  på lige til højre for koordinat-
funktionerne. Her kan man også se tilgængelige konstanter, 
makroer, operatorer og sågar custom functions (se næste 
punkt). I felterne T From og T To skrives nedre og øvre grænse 
for parameteren t. I feltet T Step kan man angive, hvor mange 
rette linjestykker man ønsker kurven sammensat af. Med (To-
From)/10 vil kurven blive evalueret i de 11 værdier for t, som 
ligger homogent spredt mellem grænserne for t. De tilsvarende 
punkter forbindes med rette linjestykker og resultatet er en 
stykvis lineær kurve, som tilnærmer den ønskede kurve. Når 
man afslutter med OK, er kurven registreret og kan ses i 
Objektmanageren udover i arbejdsfelterne. Markeres kurveob-
jektet kan det redigeres via menuen Object > Properties... 
(F4).      

Custom Functions Via menuen View > Functions... kan man definere sine egne 
funktioner. Man giver funktionen et navn og nogle parametre 
under Name and Parameters, fx ( , )f x y . Under Declaration 
skriver man forskriften for funktionen, fx. 5*x^2+y. Under De-
scription kan man skrive nogle kommentarer til funktionen, 
men disse er mest af oplysende karakter. Funktionen huskes, 
når man trykker Add. I menuen kan man også slette funktioner, 
ændre dem eller endda eksportere et funktionsudtryk i en fil 
med endelsen fnl. Den kan så eventuelt importeres i et andet 
perspektiv projekt.  
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I det følgende vil vi studere, hvad man kan gøre med et objekt. 
      
Markere objekt Klik på objektet med pegeværktøjet. Det markerede objekt far-

ves rødt. Du kan også markere objektet ude i Objekt Manager’en 
ude til højre.  

Markere flere 
objekter samtidigt 

Hold Shift-tasten nede mens du klikker på objekterne med pege-
værktøjet et efter et. Alle objekter kan markeres på en gang med 
Ctrl+A. 

Markere delobjekt Hold Ctrl-tasten nede mens du klikker på delobjektet gentagne 
gange indtil kun det ønskede delobjekt er markeret med rødt: Da 
objekterne er ordnet i en træstruktur må du arbejde dig ned 
gennem træet. Du kan dog også markere et objekt ved at klikke 
på delobjektet i Objekt Manager’en.    

Slette objekt Marker objektet og tryk på Delete-tasten på tastaturet. 
Flytte et objekt Marker objektet og træk i det. Hvis Ctrl-tasten holdes nede mens 

man trækker, bevæges objektet kun i trin svarende til maske-
vidden i gitteret! Alternativ måde at flytte på: Du kan i absolut 
tilstand ændre værdierne for Position eller, hvis der er tale om en 
linje, værdierne for Point1 og Point2. Hvis du arbejder relativt 
kan du ændre værdierne for Move. Bemærk, at Position angiver 
centrum for objektet! Endeligt kan man flytte et markeret objekt 
ved hjælp af piletasterne: Se detaljer i afsnit 7.   

Rotere objekt Marker objektet og indtast nogle vinkel-værdier for rotationen 
omkring forskellige akser i felterne Rotate – enten absolut eller 
relativt. Man kan også rotere et markeret objekt ved hjælp af 
piletasterne: Se detaljer i afsnit 7.   

Strække et objekt Du kan strække et objekt ved i absolut tilstand at ændre værdier-
ne for dets størrelse (Size) eller hvis det er en linje endepunkter-
ne (Point1 og Point2). I relativ tilstand kan du også gøre det ved 
at ændre procent-værdierne for udstrækningen i de forskellige 
aksers retning i felterne Stretch.  

Gruppere objekter Du kan gruppere flere objekter ved at markere dem samtidigt og 
vælge menuen Object > Group (Ctrl+G). Dette gør, at objektet 
bliver betragtet som ét. Du kan ophæve grupperingen via Object 
> Ungroup (Ctrl+U). 

Redigere 
knudepunkter i 
objekt 

Anvend Node Edit Tool til at markere et objekt med. Herefter 
kan du trække i knudepunkterne. Se under Ellipse Tool og Curve 
Tool, hvorledes disse objekter redigeres med Node Edit Tool.   

Kopiere objekt Du kan lave en tro kopi af et markeret objekt ved at vælge menu-
en Object > Duplicate (Ctrl+D). Du kan også bruge Ctrl+C 
efterfulgt af Ctrl+V. 

Skjule objekt Et markeret objekt kan skjules/vises via menuen Object > 
Visible (Ctrl+H). Fordelen er, at man kan undgå ”objektforvir-
ring” ved konstruktioner m.m. 
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Horisontlinje Man kan få tegnet horisontlinjen til for eksempel det vandrette 

plan ved at afmærke Show Horizon boksen i menuen View > 
Edit Perspective og bruger normalen (0,0,1). 

Linje til forsvindings-
punkt 

Man kan forlænge enhver ”dybdelinje” (linje, som ikke er pa-
rallel med billedplanen) til dets forsvindingspunkt i perspektiv-
billedet ved at markere linjen og vælge menuen Object > Vani-
shing Lines (F5). Hvis et helt objekt, bestående at mange linjer 
er markeret, forlænges alle dybdelinjer til deres respektive for-
svindingspunkter. Husk at afmærke Enable Vanishing Lines 
boksen i menuen View > Edit Perspective.    
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5. Perspektivet 

Dette afsnit handler om perspektivet, dvs. hvordan scenen betragtes og hvordan billed-
planen er indrettet. Før du læser dette afsnit er det vigtigt, at du har læst afsnit 2 om pro-
grammets opbygning. Hvordan scenen betragtes beskrives her ved hjælp af et kamera: 
Kameraets position og kameraets orientering. Positionen er det samme som øjepunktet, 
mens orienteringen er bestemt ved en synsretning og en view-up-vektor. Sidstnævnte 
vektor er med til at bestemme, hvad der er op i billedplanen. Hvis planen udspændt af 
synsretningen og view-up-vektoren ikke er en lodret plan, siger vi, at kameraet er tiltet.  
 
Ændringer i perspektivet kan foretages via menuen View > Edit Perspective. Edit Per-
spective dialogboksen kan også åbnes ved i værktøjslinjen at klikke på knappen med 
øjet. Nogle af ændringerne for perspektivet kan dog også foretages direkte i de tre pro-
jektionsfelter: Her ser du (formentlig) en lille blå pil (synspilen) med et stort og et lille 
rødt kvadrat for enderne. Hvis du trækker i det store røde kvadrat, flytter du øjepunktet 
(Eye Point) i det pågældende felt. Hvis du trækker i det lille røde kvadrat ændrer du 
synsretnings-vektoren (Viewing Direction). Hvis Shift-tasten holdes nede samtidigt med 
at man trækker i øjepunktet, så aktiveres ”Snap-to-Grid”. Hvis synspilen skulle komme 
ude af syne, enten ved at man trækker den udenfor arbejdsfeltet eller man gør scenen 
mindre, så kan man skaffe den indenfor igen ved at klikke på Reset Eye Point knappen i 
værktøjslinjen. Så vil øjepunktet blive valgt til det ”øverste højre hjørne” af scenen, 
synsretningen rettet mod scenens midtpunkt og view-up-vektoren sat til (0,0,1). Kame-
raets position og orientering kan også styres ved hjælp af piletasterne både set i forhold 
til selve scenen og i forhold til kameraet. Detaljer om piletasternes funktion finder du i 
afsnit 7. Nu tilbage til dialogboksen Edit Perspective:    
 
 
Eye Point Øjepunktet beskriver det punkt i Verdens koordinatsystemet, 

hvorfra scenen med objekterne betragtes. Det kan ændres ved 
at du indtaster ( , , )x y z -koordinaterne for punktet.    

Viewing Direction Angiver koordinaterne for synsretnings-vektoren (se afsnit 2).  
View-Up Vector Angiver løst sagt, hvordan kameraet er tiltet (se afsnit 2). Nor-

malt er denne vektor sat til (0,0,1), hvilket betyder, at kamera-
ets ”længdeakse” givet ved vektoren v kommer til at befinde 
sig i en lodret plan. Hvis man ser scenen lodret oppefra, dvs. 
hvis synsretningsvektoren for eksempel er (0,0,–1), så er man 
nødt til at ændre View-Up Vector, for eksempel til (1,0,0). 

Distance Distancen d er den afstand, som billedplanen er anbragt fra 
øjepunktet i retningen angivet ved Viewing Direction. En ænd-
ring af distancen vil blot medføre en skalering af det perspekti-
viske billede – en ligedannet transformation. Distancen kan 
altså bruges til at regulere størrelsen af det endelige perspekti-
viske billede. Prøv selv at ændre den og se, hvad der sker med 
linealerne i feltet Perspective.   
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Field of View Field of View dropdown listen er med til at beskrive synsfeltet set fra 

øjepunktet. Der er en række muligheder: Custom, Angle, 1:2, 1:1, 2:1, 
3:1, 4:1.  
 
Custom giver mulighed for helt frit at vælge et rektangel som View 
Window, beskrevet ved diagonalpunkterne  og  
–  se igen i afsnit 2.  

min min( ,u v ) )max max( ,u v

 
Angle angiver synsvinklen (se afsnit 2). Hvis du indtaster en værdi w 
for denne, vil der på grundlag af denne værdi samt den værdi α, som 
du har indtastet for -ratiou v , automatisk blive beregnet et View 
Window, beliggende symmetrisk omkring hovedpunktet :  vC

min min( ,1) tan( )u d= − α ⋅ ⋅ w  

min min(1 ,1) tan( )v d= − α ⋅ ⋅ w
w

 

max min( ,1) tan( )u d= α ⋅ ⋅  

max min(1 ,1) tan( )v d= α ⋅ ⋅ w  
 
Distanceforholdene 1:2, 1:1, 2:1, 3:1, 4:1 i dropdown listen er angivet 
af hensyn til den måde arkitekter ofte angiver synsfeltet på. Se afsnit 2 
for en nærmere definition. De anførte distanceforhold svarer egentlig 
bare til nedenstående synsvinkler, således, at man blot får et specialtil-
fælde af punktet Angle.  

1:2  ( )1 2
1tan 63,4349w −= = °  

1:1  ( )1 1
1tan 45,0000w −= = °  

2:1  ( )1 1
2tan 26,5651w −= = °  

3:1  ( )1 1
3tan 18,4349w −= = °  

4:1  ( )1 1
4tan 14,0362w −= = °  

min min, ,u v min min( , )u v ) 

max max,u v  
 og  beskriver View-Window rektanglet i VRC 

systemet (se afsnit 2).  
max max( ,u v

Angle Når feltet Angle er ”greyed out” viser feltet til enhver tid synsvinklen, 
som den er defineret i afsnit 2. Hvis Angle er valgt i dropdown listen 
for Field of View, kan du selv sætte synsvinklen w. Da vil View Win-
dow blive beregnet efter formlerne angivet ovenfor under punktet 
Field of View. 

-ratiou v  Angiver forholdet mellem udstrækningen af View-Window i hen-
holdsvis u- og v-retningen. En værdi på 2 1,41≈  vil for eksempel 
betyde, at du har de rette proportioner til et A4 papir, som ligger ned. 

-ratiou v  er ikke relevant, hvis Field of View > Custom er valgt.  
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Front (Line Clipping) Angiver afstanden fra Front Clipping Plane til View Plane 

regnet med fortegn: Positivt imod øjet og negativ væk fra (Se 
figur 4 i afsnit 2). En værdi på 0 svarer altså til at kun det bag 
billedplanen afbildes. Man kan ikke vælge en værdi, som er 
større end distancen d.   

Back (Line Clipping) Angiver afstanden fra Back Clipping Plane til View Plane 
regnet med fortegn: Positivt imod øjet og negativ væk fra. 
(Se figur 4 i afsnit 2). En værdi på –100 svarer altså til at alt, 
som har en n-koordinat mindre end –100, skæres bort.  

Show Horizon Her kan du slå tegningen af horisontlinjen fra/til 
Enable Vanishing Lines Her kan du slå tegningen af linjer til forsvindingspunkter 

fra/til. 
Show Centre Of View Her kan du slå visning af et ”sigtekorn” til/fra. Skærings-

punktet er hovedpunktet og har koordinaterne ( . , ) (0,0)u v =
Horizon Plane Normal Her kan du angive normalvektoren til den plan, hvis hori-

sontlinje du ønsker tegnet. Almindeligvist vil det være en 
vandret plan med normalvektor (0,0,1). 

Horizon Plane Offset Her kan man indtaste den værdi, man ønsker horisontplanen 
forskudt i normalens retning – se forrige punkt.   
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6. Gemme, åbne, lukke, udskrive, eksportere m.m. 

Du kan gemme dine perspektiv projekter med alle indstillinger i en fil via File > Save 
eller File > Save As... Filens extension er .pmp. Hvis flere filer er åbne samtidigt, kan 
du gemme dem alle på en gang via File > Save All. Du kan senere åbne perspektiv pro-
jekt-filer via File > Open... og lukke dem via File > Close.  
 
Du kan også printe enhver af de fire projektioner ud på papir. Marker først det ønskede 
felt, så der dannes en rød kant om feltet. Du kan så vælge File Print..., men du kan også 
vælge først at se på, hvordan udprintningen kommer til at se ud, ved at vælge File > 
Print Preview. Først vises muligvis en Indstil Printer dialogboks, hvor du blandt andet 
kan vælge, hvordan papiret skal vende. Efter OK, vises Print Preview dialogboksen. 
Hvis billedet kan være på papiret, vil feltet Fit View To Page være utilgængelig. Hvis 
derimod billedet ikke kan være på papiret, så kan du vælge at afmærke dette felt, så 
billedet skaleres ned, så alt kan være på papiret. Hvis du ikke afmærker feltet vil kun en 
del af billedet blive printet ud, nemlig den del, som vises med en ramme i dialogboksen. 
Du kan også vælge, om der skal tilføjes en ramme eller ej udenom billedet via feltet Add 
Frame, og om der skal tegnes gitterlinjer via Show Grid. I dialogboksen View kan du 
endvidere hurtigt skifte mellem de forskellige projektioner...  
 
Endelig kan du også eksportere de forskellige projektioner til CorelDRAW, hvis du er i 
besiddelse af en af de senere versioner af dette program. Jeg vil lade læseren selv eks-
perimentere nærmere med dette. En anden mulighed er at eksportere i vektorgrafikfor-
matet emf (Enhanced Meta File). Her skal du først markere det felt, du ønsker at ekspor-
tere og herefter vælge File > Export... En emf-fil kan for eksempel senere indsættes 
som et billede i MS Word og redigeres på forskellig vis heri.  
 
Man kan også importere en pmp-fil i en anden via File > Import.... Hvis man kun øn-
sker at genbruge et enkelt objekt fra en anden pmp-fil i en anden pmp-fil, så kan dette 
gøres ved at åbne begge filer i samme Perspective Modeler-vindue, kopiere det ønskede 
objekt fra den ene fil med Ctrl+C, vælge fx Window > Tile Vertical for at få få fokus på 
den anden pmp-fil og sætte objektet ind med Ctrl+V.  
 
Med Undo/Redo knapperne i værktøjslinjen kan du fortryde eller gentage en handling, 
men bemærk, at hvis du lige har foretaget en ændring ved at indtaste nogle tal i felterne 
i det brede bånd forneden, så kan man først anvende knapperne, hvis man klikker et sted 
udenfor felterne! Hvis du benytter piletasterne adskillige gange efter hinanden, vil pro-
grammet gruppere handlingerne indenfor 3 sek. og hvis du herefter benytter Undo vil du 
komme tilbage til starten af sekvensen! 
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7. Piletasternes funktioner 

Piletasterne kan benyttes til at flytte et objekt eller kameraet, eller de kan benyttes til at 
dreje et objekt eller kameraets orientering. Kameraets position er det samme som øje-
punktet og kameraets orientering beskriver, i hvilken retning kameraet peger og om det 
er tiltet. Vi har det såkaldte VRC (Viewers Reference System). Det er koordinatsyste-
met udspændt af  højrehåndssystemet (  bestående af  indbyrdes ortogonale en-
hedsvektorer, som det også ses på figur 2. Synsretningen kan beskrives ved . Vekto-
ren v fortæller, hvad der er ”op” for kameraet, og vektoren u fortæller, hvad der er til 
højre. Alle flytninger foretages med en størrelse svarende til maskevidden i det sekun-
dære gitter (Minor Grid Spacing), hvis andet ikke er specificeret i Scene Properties dia-
logboksen (F6) under Nudge Offset. Tilsvarende udføres alle rotationer med 3°, hvis 
ikke andet er specificeret i samme dialogboks under punktet Rotation Increment.   

, , )u v n
n−

 
Piletasterne kan have forskellige funktioner alt efter hvilket af de fire felter Top, Left, 
Front eller Perspective, der er aktiveret. De tre førstnævnte felter kalder vi under ét for 
projektionsfelterne. Hvis intet objekt er markeret og et af de tre projektionsfelter er akti-
veret, så vil øjepunktet for eksempel blive flyttet langs akserne i Verdens-koordinatsy-
stemet WC, på intuitiv vis i hvert af de tre felter. Hvis derimod feltet Perspective er 
aktiveret, så vil øjepunktet bevæge sig langs akserne i VRC.  
 
På tilsvarende måde kan man rotere synsretningen på forskellig vis i projektionsfelterne 
i forhold til feltet Perspective. I projektionsfelterne vil synsretningen blive roteret om 
Horizon Plane Normal N, som normalt er vektoren (0,0,1), men kan ændres i Edit Per-
spective dialogboksen. Med Shift + →  vil synsretningen blive drejet mod uret, mens 

 vil dreje den med uret omkring normalen. Kombinationerne Shi  og 
 vil få synsretningen til at rotere omkring vektoren 

Shift + ← ft + ↑
Shift + ↓ N n× . Hvis , 
som er default-værdien, og hvis synsretningsvektoren 

(0,0,1)N =
n−  ikke er rettet lodret, vil det 

betyde, at synsretningen vil dreje i det lodrette plan, som går igennem synsretningen. 
Disse to dreje-faciliteter er velegnede til hurtigt at dreje synsretningen i den ønskede 
retning, efter at øjepunktet er flyttet hen i den ønskede position! Hvis derimod feltet 
Perspective er aktiveret, så foregår rotationerne i forhold til VRC. Det vil betyde, at 
drejningerne her foregår mere, som man kan forestille sig piloten i et fly vil opleve det. 
Kombinationerne  og ShiftShift + ← +→  vil betyde en drejning mod henholdsvis 
venstre og højre i ”flyets plan”. Kombinationerne Shift + ↓  og Shi  vil betyde at 
”flyets snude” henholdsvis tippes nedad og opad. Endelig vil kombinationerne 

 og  betyde en tiltning, hvor henholdsvis ”flyets venstre 
vinge” og ”flyets højre vinge” vippes nedad.  

ft + ↑

Ctrl Shift+ + ← →Ctrl Shift+ +

 
Som nævnt ovenfor kan man flytte øjepunktet i forhold til VRC, hvis feltet Perspective 
er aktiveret. Hvis vi igen benytter fly-analogien, så har vi her en meget vigtig anvendel-
se: Med  kan man få flyet til at bevæge sig lige fremad i synsretningens retning! 
Denne facilitet kan bruges til at illustrere perspektiviske forkortningers afhængighed af 
observatørens afstand fra genstanden! I det følgende en liste over piletasternes funktion.  

Ctrl+ ↑
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Flytte objekter 

Hvis nogle objekter er markeret og et af de tre projektionsfelter er aktiveret, så bliver 
objekterne flyttet på nedenstående vis. 
  

Ctrl Shift Pil Beskrivelse 
  Venstre Flytter mod venstre i feltet 
  Højre Flytter mod højre i feltet 
  Op Flytter opad i feltet 
  Ned Flytter nedad i feltet 
•   Op Flytter ud af feltet 
•   Ned Flytter ind i feltet 

 
 
Flytte kameraets position 

Dette er det samme som at ændre øjepunktet! Her anvendes de samme idéer, som i 
tilfældet med flytning af objekter! Hvis intet objekt er markeret og et af de tre projek-
tionsfelter er aktiveret, så flyttes øjepunktet på følgende måde:  
 

Ctrl Shift Pil Beskrivelse 
  Venstre Flytter mod venstre i feltet 
  Højre Flytter mod højre i feltet 
  Op Flytter opad i feltet 
  Ned Flytter nedad i feltet 
•   Op Flytter ud af feltet 
•   Ned Flytter ind i feltet 

 
 
Hvis feltet Perspective er aktiveret, så bevæges øjepunktet i forhold til VRC: 
 

Ctrl Shift Pil Beskrivelse 
  Venstre Flyttes mod venstre i forhold til kameraets orientering 
  Højre Flyttes mod højre i forhold til kameraets orientering 
  Op Flytning opad i forhold til kameraets orientering 
  Ned Flytning nedad i forhold til kameraets orientering 
•   Op Flyttes fremad i forhold til kameraets orientering 
•   Ned Flyttes tilbage i forhold til kameraets orientering 
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Ændre kameraets orientering 

Alle ændringer her handler om rotationer. Disse rotationer foretages enten “i forhold til 
Horisont-planen” eller i forhold til VRC.   
 
Hvis intet objekt er markeret og et af de tre projektionsfelter er aktiveret, så bliver rota-
tionerne foretaget i forhold til Horisont-planen, på følgende måde: 
 

Ctrl Shift Pil Beskrivelse 
 •  Venstre VRC drejes mod uret rundt om Horizon Plane Normal 
 •  Højre VRC drejes med uret rundt om Horizon Plane Normal 
 •  Op VRC drejes med uret rundt om aksen ( )N n N n× × . Dette 

vil dreje synsretningen i en plan vinkelret på Horisont-planen. 
 •  Ned VRC drejes mod uret rundt om aksen ( )N n N n× × . Dette 

vil dreje synsretningen i en plan vinkelret på Horisont-planen. 
 

 
Hvis feltet Perspective er aktiveret, foretages rotationerne i forhold til VRC: 
 

Ctrl Shift Pil Beskrivelse 
 •  Venstre Drejning mod venstre i forhold til kameraets orientering 
 •  Højre Drejning mod højre i forhold til kameraets orientering 
 •  Op Drejning opad i forhold til kameraets orientering 
 •  Ned Drejning nedad i forhold til kameraets orientering 
•  •  Venstre Tilter kameraet mod venstre 
•  •  Højre Tilter kameraet mod højre  

 

 
Bemærkning 
Hvis man markerer nogle objekter i Object Manager’en (OM), så kan man ikke straks 
benytte piletasterne til at flytte eller rotere disse objekter, da piletasterne i OM har en 
anden funktion. Man kan dog gøre følgende, hvis man ønsker at bruge OM til at marke-
re objekterne: Marker først de ønskede objekter i OM, aktiver derefter det felt, du vil ar-
bejde i. Herefter kan piletasterne benyttes til at flytte/rotere de markerede objekter. Be-
mærk dog, at hvis det felt, du vil arbejde i, allerede er aktiveret, så skal du lige først ak-
tivere et andet og derefter det ønskede, for hvis du prøver at aktivere et felt, som allere-
de er aktiveret, vil markeringerne tabes! 
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